Sunday 9th July 2017

Scheduled maintenance

We will start our scheduled maintenance shortly, no QBank (shared hosting) services will be reachable during this time.

This is includes Backend, API and Frontend.

Update 00:17 We're about half way through our upgrades, currently ahead of schedule.

Update 02:43 We have finished our scheduled maintenance.