Tuesday 22nd August 2017

Backend Investigating SSL revocation status for *.qbank.se

Some customers have reported that their browsers are complaining about our wildcard *.qbank.se certificated is not trusted, we are investigating this issue.

Update 11:46 We have received a response from our certificate issuer;

Hello,

Due to an unexpected incident, a number of certificates issued in early May have been revoked. We regret this occurrence and are working to rectify this situation as soon as possible.

Please complete the pending certificate validation request using the link below.

redacted

Please let us know if you have any other questions we're always glad to help.

Regards,

George SSL Support Team support@ssl.com

SSL Support Team support@ssl.com http://www.ssl.com

Ticket Details Ticket ID: BMB-221-20409 Department: Support Type: Issue Status: Open Priority: Critical

Update 11:51 New certificate that is not revoked have been installed on backend servers, we are working on checking other services if they need new certificates as well.