Our servers are experiencing some operational disturbance, we are working hard together with our service provider to resolve this issue.
Update: The issue has been identified and we are currently working to resolve it. Most operations are now back in service, but not all.
Update 2: We have now closed down access to QBank while we ensure data integrity.
Update 3: Access to QBank is now restored as we are satisfied with the data integrity check.
Update 4: Performance should now be back to normal. We have some ongoing maintenance operations after the outage, but nothing that will affect availability or performance.